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Symbols and Links

Kidspiration Basics Version 2

Adding Symbols

1. Type a topic in the center symbol.

2. Click the Add Symbol tool,
This will add a symbol which will be linked to the first
idea symbol.

3. Click and type a subtopic in the new symbol.

4. Continue to click, type, and add symbols until your web
is complete.

Adding Links

1. Click 1o select the symboi from which you want to link.
2. Click the Link Symbols icon.

3. Click the symbol to which you want to link.

Moving / Resizing Symbaols

I. Click and drag the center of a symbol to move it 1o the
desired jocation.

2. Click and drag one of the corner handlepoints to resize a
symbol.
Note: click anc drag the bottom right hand corner to
maintain the proportions while resizing.

Symbo! Colors
. Click to select the desired symbols:
a. Click one symbol lo select it.
h. Hold the Shift key on the keyboard while you click to
select muliiple symbols,
c. Pull down the Edit menu to Select All to select all
symbols.
2. To change the border color, click the Line Color icon at
the bottom of the screen. Select the desired color.
3. To change the fill color, click the Fill Color icon af the
bottom of the screen. Select the desired color,

Lmk Options
1. Click to select the desired symbols:
a. Click one link to select it.
b. Hold the Shift key on the keyboard and click to select
multiple links.
symbols and links.
2. If desired, click in the shaded rectangle and type to add text
to the link.
3. Click the arrow to toggle through: no arrows, one arrow,
two arrows.
4. Click the line width icon to toggle through various line
widths: thin, medium, thick, dashed.
5. Click the Link Color icon to choose a color for the link.
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Create It With Kidspiration!

ﬁgf Images

Using Images as Symbols

1. Click 1o select the desired symbol(s) on the screen.

2. Use the arrows at the top of the symbol library palette to
scroll through the available graphics.

3. Choose a graphic and click.

4. The symbol(s} you selecied in slep one will be replaced
by the graphic you just chose.
or

1. Click to select a graphic from the symbol library palette
and drag it onto the screen.

Pasting Graphics from Other

Sources

I. From another program, select and copy a graphic.

2. Return to Kidspiration.

3. Paste the graphic. (Pull down the Edit menu to Paste.}
The graphic automatically becomes a symbol,

Inserting Graphics from Other

Sources

I. From the File menw, choose Import a Graphic.

2. Find & graphic on your hard drive, disk, or CD-ROM.
3. Click to select the desired graphic file and click Open,

Using Graphics from the Internet
1. Find a graphic on the internet at a royalty free clip art
site.

Option 1:

1. Macintosh - Click the graphic and hold (or Control -
click) until a menu appears.
Windows - Right click and a menu will appear.

2. Choese Copy Image or Copy this Image.

. Return to Kidspiration.

4. Putl down the Edit Menu to Paste.

i Internel Exglorerbelp..,

’ ﬁpeni’rﬂa’gé i New windaw
Dowrioad Image 10 DK

L

Option 2:

1. Macintosh - Click the graphic and hold until a menu
appears,
Windows - Right click and a menu witl appear.

. Choose Save Image As; Save Picture As; or Download
image to Disk.

. Return to Kidspiration.

. Pull down the File menu to Impost a Graphic.

. Find the image you just saved from the web.

. Click Open.

b

o boto

o

Note -- animated graphics will also work in Kidspiration.
Be sure to use Option 2 above,
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Kidspiration Basics Version 2

Customizing the Symbol Library

Adding Symbols to the Library

1. Paste or import a new graphic onto the page.

2. Click to select the graphic,

3. Pull down the Teacher menu to Install User Symbol.
4, Choose the size of your symbol.

This wilt add your graphic to the Custom library category.

Adding Symbol Library Categories

1. Pull down the Teacher menu to New Symbo! Library. wegory:

2. Enter a name for the new category. Sestemliba
3. Click OK.

Editing the Symbol Libraries

1. Pull down the Teacher menu 1o Edit Symbol Libraries.

2. You can edit up to two symbol libraries at a time:

Rearranging the symbols within a library
Click a symbol and drag it fo another position within the
same Hbrary.

Deleting a Symbol from a Library
Click the symbol you want 10 delete and drag it to the
trash can.

Changing the label of a symbol
1. Click the desired symbot.
2. In the [abel window, enter a new label.

Import Graphic

1. Click the Import Graphic button.

2. Find the desired graphic on your hard drive, disk, or CD-ROM.
3. Click Open

The imported graphic will be added to the Custom category.

Paste Graphic

1. Copy an image from the Internet or from another application.
2. In the Edit Symbol Libraries window, click Paste Graphic.
The pasted graphic will be added to the Custom category.

New Library

1. Click the New Library bution.

2. Choosc a category from the pull down menu.
3. Enter a Name for your new library.

4. Click OK.
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Createx It With Kidspiration!

B
<9¥" Using the Symbol Maker

Getting Started

I. Click to selecs the desired symbol on the screen F o
OR S e
Click a blank area on the screen. Syl Maker |

Note - If you select a symbol on the screen, it will be
repiaced by whatever you create in the Symbol Maker.

2. Click the Symbot Maker icon at the top of the screen.
This will take you into the Symboel Maker area.

Exploring the Symbol Maker Window

Tools
Use the top eight tools to
draw, paint, add lines, and add

shapes. \

Use the rectanguiar or the A
Jasso tooks to select and move
portions of the painting.

Use the Stamp tool to add

shapes, numbers, and {etters.
~_

Click the Undo kool if you ™

make a mistake,. ——

Use the Clear ool io erase
portions of your painting, -~

Click the trash can Lo clear thc/ / |

entire painting area.

e

Options " Color Palette

Use the eptions to change Select colors using
the shape and size of the the color paletie.

paint brush and spray can.
Stamp Options

When the stamp (oo} i3 Use the stamp options to change
selected, use the options fo the size, to rotate, or {o {lip the
choose the desired shape, stamp before you stamp it onlo
letter, or number. the screen.

Creating a Symbol

i. Use the tools, options, and color paletie to create a
design.

2. Click Done.

3. Your design will appear on your Kidspiration screen.
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Text Options

Kidspiration Basics Version 2

Fonts, Sizes, Styles, Colors

1. Click to select the desired symbols and links:
a. Click one symbol or link fo select it.
b. Hold the Shift key on the keyboard and click to select
multipie symbols and Hnks,
c. Puli down the Edit menu to Select All to select all
symbols and links.

2. To change the font, click the arrows at the bottom of the
screen 10 scroll through the font options.

3. Click the Text size arrows 10 resize the {ext,
a, The top arrow makes the font size larger.
b. The bottom arrow makes the font size smaller.

4. Click one of the three text style icons to change the text
to Bold, Italic, or Underline.

5. Click the Text Color icon 1o select and change the color
of the text.

Using Text from the Internet
1. Find the desired information on a web page.
2. Click and drag to select the desired text,

3. From the Edit menu, choose Copy.

4. Return to Kidspiration

5. Pull down the Edit menu to Paste.

Creating a Hyperlink to a Web Page
Option 1:
1. Type a web address.
It will automatically become a hypertink:
Option 2:
I. Find the desired web page on the Internet.
2. Select the address in the toolbar at the top of the screen.
3. Pull down the Edit menu to Copy,
4. Return to Kidspiration.
5. Pull down the Edit menu to Paste.
The address will automatically become a hyperlink.

To activate a hyperlink, click the underlined text.
{This does require an active Internei connection).

Spell Check

1. Puli down the Goodies menu to Spell Check.

2. Move through the questionable words by choosing to
Change to or Ignore the provided alternatives.
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Create It With Kidspiration!

q@iﬁ SuperGrouper

What is a super grouper?

A SuperGrouper acts as a container to hold symbols.
Moving a SuperGrouper will also move all of the symbois
contained within it.

Adding a SuperGrouper

I. Click the SuperGrouper icon in the toolbar at the top of
the screen.

2, Pull down to choose a SuperGrouper shape,

3. Move the SuperGrouper to the desired area of the window.

ol
i h
E2s

Moving / Resizing SuperGroupers

1. Click and drag the center of a SuperGrouper to move it to
the desired location.

2. Click and drag one of the corner handlepoints (stars) to
resize a SuperGrouper.
Note: click and drag the botiom right hand star 1o
maintain the proportions while resizing.

Adding a Labei
L. Click the text box at the top of the SuperGrouper,
2. Enter the desired text fabel,

SuperGrouper Colors | Syrnbol Colors |

1. Click to select the desired SuperGrouper: o
2. Click the symbol colors icon at the bottom of the screen

to change colors.

Enter vour text here.

Adding Symbols To a SuperGrouper

1. Choose a symboi from the symbol library palette or from
the screen.

2. Click and drag the symbol onto the SuperGrouper,

3. Release the mouse button.

Removing Symbols From a

SuperGrouper

L. Click the symbol and drag it away from the SuperGrouper.
or

2. Click the symbol and press the Deiete key.
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Kidspiration Basics Version 2

Background Color / Sounds a@‘x

Changing Background Color - He

1. Puli down the Goodies menu to Change 5 cRiEE
Background Color.

2. Select the desired color.

Recording Sounds

{Requires a computer with microphone.)
1. Click to select a symbol.

2. Pull down the Sound menu to Record.
3. Click Record. {The Circle button)

4. Speak or record the desired sound,

3. Click Stop. (The Square button)

6. Click Save.

Listening to Recorded Sounds
(Requires a computer with speakers.)
1. While stili in the recording window, click the
Play button. (The Triangle button)
or
2. Click the speaker icon on the symbol,

Erasing Recorded Sounds

1. Click fo select the symbol with a recorded
sound.

2. Pull down the Sound menu to Erase.

The Listen Tool

I. Click to select the Listen tool at the {op of the
SCreern.
Note - clicking the Listen tool toggles it off
and on.

2. Click a symbol (or any object with text.}

3. The computer will read the text to you.

Changing the Voice

1. Pull down the Sound menu to Voices,
2. Click each voice to hear a sample.

3. Click to select the desired voice,

4. Click Choose to change the voice.
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Create It With Kidspiration!

,.@w’ Writing Mode

Entermg Text

. Select “First {dea”.

2. Begin typing to replace “First Idea”™ with your own
fext.
(Text entered above the top line will become the
topic. This text will show in the picture view.)

3. Click below the top line to enter supporting
information.
(Text entered below the top line is supporting
information. It will not show in the picture view.)

R s

Main im:a L
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Adding/Moving Ideas

1. Click the Add Ideas icon in the op tooibar 1o add a
new paper.

2. Click the left and right facing arrows to move the idea
to the left or right.

3. To rearrange the ideas:
a. Click away from the ideas {0 deselect them,
b. Click the desired idea and drag it to a new position.

Changing Paper Colors

£, Pull down the Goodies Menu to Lined Paper Colors.

2. Choose the desired colors for the paper background
and the lines.

Fonts, Sizes, Styles, Colors

Use the tooibar at the bottom of the page to choose the font, {7 s A A4 A K
size, styie, and color,

Changing the Prefix

Click the Prefix icon in the toolbar al the bottom of the page
to toggle through the following prefix options:

t. No prefix.

2. Bullets

3. AlphaNumerals

4. Roman Numerals

5. Numeric

Hide/Show Paper
Click the Show or Hide Paper icon in the tooibar at the
bottom of the page o toggle between hide paper and show

paper.

Hide Paper
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Saving / Exporting / Printing

Saving the Document
1. Pull down the File menu 1o Save.

2. Enter a name for the document,
3. Maneuver (o the desired iocation.
4. Click Save.

Exporting Options

1. Pull down the File menu to Export. o . o
2. Choose the desired format, i RGN B o
3. Click Save. g 5

Writing View Export Options:
+ Plain Text

* AppleWoris (RTE)

» Microsoft Word (RTF)

« HTML

Picture View Export Options:
* PICT

* GIF

¢ JPEG

* HTML

Addmg a Page Header
. Click the Student Name icon in the toolbar at the
top of the screen.
2. Enter the desired header information to print at the
left, center, and right of the header area.
3. Choose whether or not you want page nuntbers to
print.

= .
Stutent Hame

Printing

1. Pull down the File menu to Page Setup.

2. Choose between portrait (vertical) and landscape
{horizontal) orientation.

AT EIE LRI

3. Pull down the File menu to Print.
4. Change options if desired.
5. Click Print.
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Create It With Kidspiration!
Activities

Activities are templates. Students can open
the files and make changes to them, but the
original fifes will remain unchanged so that
they can be used over and over.

Choosing an Kidspiration

Activity

1. Pull down the File Menu to New,

2. Choose one of the Activity categories.

3. Scroll through the activities and select
one.

4, Click OK.

Creating Your Own Activity

I. Open a new Kidspiration document.

2. Add symbois and text as desired.

3. Pull down the Teacher menu (o Save

with Activity Wizard.

4. The wizard will lead you through the
process of creating and saving your
activity.

. Once your activity is saved, it wiil
appear as one of the options from the
Kidspiration startup window {as shown
above).

(¥

Using the Create It With

Kidspiration CD

The examples included with the Create It

With Kidspiration CD are saved so that

they can be edited o fit your needs. To turn

a example file into an activity:

]. Open an example file from the CD.

. Make changes o the file if desired.

. Pult down the Teacher meny (o Save as
Activity.

4. The wizard will fead you through the
process of creating and saving your
activity.

_ Once your activity is saved, it will
appear as one of the options from the
Kidspiration startup window.

[FS 0 ]
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